Actualizaciones que desactualizan (WP 3.0.3)

Publicado por el día 9 Dic, 2010 |


Una de las cosas que se habla hoy en las listas de correo de WordPress se refiere a las actualizaciones desactualizadoras. No es la primera vez que nos las encontramos y es interesante comentarlas.

Qué son

Una actualización desactualizadora es una actualización que, a la vez, desactualiza (instala una versión anterior) de un software.

Por qué ocurre

Ocurre porque en el trunk de esa instalación existe una versión anterior de un plugin. En este caso concreto, Akismet 2.5 está en la calle. Si lo hemos instalado en nuestro sistema y actualizamos el sistema a la versión 3.0.3 de WordPress, éste volverá a la versión 2.4. Esto es porque la actualización de seguridad corrige un error de WP 3.0, versión que, inicialmente, trae la versión 2.4 de Akismet.

Si vuestro sistema se desactualiza no os asustéis. El primer paso es comprender por qué ocurre, y volver a actualizar Akismet a la versión 2.5, versión que está incluida en la versión 3.1 de WordPress

El futuro

En el futuro (WP 3.2) se trabajará para que estas regresiones, que también sufren los paquetes de idiomas, no ocurran. Ya está apuntado en el gran tablón :).